|
Login

Ricerca Tips

Creare riferimenti variabili - SCARTO
(7 VOTITALY_VOTES, VOTITALY_AVERAGE: 4.57 VOTITALY_OUTOF)
Tips and Tricks - Formule

Un argomento molto sentito è la creazione di intervalli dinamici che cambino in funzione di alcune variabili. Tra le funzioni che consentono di raggiungere questo obiettivo, c'è SCARTO(), che permette di ottenere o un riferimento da utilizzare in un'altra formula o il valore di una cella.

SCARTO() conta quattro argomenti: rif, righe, colonne, altezza, larghezza.

  • rif è la cella o l'intervallo di partenza, cioé quel riferimento a una cella a partire dal quale calcoleremo il nuovo intervallo
  • righe è il numero di righe da saltare per determinare l'inizio del nuovo intervallo/cella
  • colonne è il numero di colonne da saltare per determinare l'inizio del nuovo intervallo/cella
  • altezza consente di specificare quante righe devono essere incluse a partire dalla cella rif + righe. Se rif = A1, righe = 1, altezza = 10, SCARTO restituirà il range A2:A12, cioé 10 righe dopo la cella A2 che corrisponde a 1 riga dopo A1
  • larghezza fa la stessa cosa di altezza, ma determina il numero di colonne da includere nell'intervallo

Ecco alcuni esempi.
=SCARTO(A1; 9; 0) riporterà il valore della cella A10
=SCARTO(A1; 0; 6) riporterà il valore della cella F1
=SOMMA(SCARTO(A1; 1; 0; 10; 1)) sommerà l'intervallo A2:A12
=SOMMA(SCARTO(A1; 0; 0; 10; 5)) sommerà l'intervallo A1:E11
=SOMMA.SE(A:A; criterio; SCARTO(A1; 0; 1; 65535)) sommerà condizionalmente i dati della colonna B.

 

Per un esempio più articolato si veda qui