|
Login

Ricerca Tips

Convalidare gli inserimenti dell'utente
(2 VOTITALY_VOTES, VOTITALY_AVERAGE: 4.50 VOTITALY_OUTOF)
Tips and Tricks - Strumenti

A volte si ha l'esigenza di impedire che un utente inserisca dei dati non validi. Per questa e altre funzionalità, possiamo far ricorso a Convalida Dati

 

La funzionalità che si trova nel menu Dati, consente di circoscrivere le immissioni di un utente per ogni singola cella che questi dovrà modificare. La prima cosa da fare è comunque selezionare la cella o il range di celle che sarà oggetto della convalida. Poi, dal menu Dati, sceglieremo Convalida Dati e procederemo all'inserimento di restrizioni. Vediamo qualche esempio semplice:

  • per obbligare l'utente a inserire una data tra il primo gennaio e il trentun dicembre 2007, dovremo scegliere Tra nella casella Dati e immettere la data di inizio e di fine dell'intervallo. Le date inserite possono anche far riferimento a qualche cella del foglio in oggetto oppure a un Nome
  • se vogliamo che il nostro utente digiti un testo non superiore di una certa lunghezza dovremo scegliere Lunghezza testo nella casella Consenti e impostare la lunghezza minima e massima
  • se vogliamo obbligare l'utente a inserire un testo, dovremo scegliere Personalizzato nella casella Consenti e digitare la formula =VAL.TESTO(A1)
  • per far sì che la somma di valori dell'intervallo B2:B5 sia inferiore o uguale a un certo totale (tipico caso di budget) usiamo sempre Personalizzato e digitiamo =SOMMA($B$2:$B$5)≤1000