|
Login

Ricerca Tips

CERCA.VERT senza segreti - 3
(6 VOTITALY_VOTES, VOTITALY_AVERAGE: 4.83 VOTITALY_OUTOF)
Tips and Tricks - Formule

Uno dei presupposti fondamentali per far funzionare bene la funzione CERCA.VERT è che le tabelle siano ordinate: se questa condizione non è vera, il calcolo è molto più lento.

 

L'ordinamento diventa imprescindibile quando usiamo l'approssimazione. Di solito, l'approssimazione (4° argomento di CERCA.VERT) porta più danni che benefici. Esiste tuttavia un caso in cui conviene impostare il quarto argomento su VERO.

 

Quando la tabella di riferimento rappresenta dei range ordinati di dati, questa funzionalità torna incredibilmente utile. Immaginiamo di voler classificare un'età in base a 4 livelli: fino a 15 bambino, da 16 a 35 adulto, da 36 a 50 high spender, da 51 in su fuori target. Anziché usare un SE, possiamo seguire questa strada:

  • nel range A1:A4 scriviamo 0, 16, 36, 51 e nella colonna accanto le categorie relative
  • nella cella D1 inseriremo un numero e faremo in modo che la cella E1 riporti la categoria
  • in E1 dovremo scrivere
    =CERCA.VERT(D1; A1:B4; 2; VERO)

Qualunque numero da 0 a infinito sarà classificato senza problemi.

 

 

Tips correlati: