|
Login

Ricerca Tips

Creare somme condizionali con funzioni alternative - Seconda Parte
(4 VOTITALY_VOTES, VOTITALY_AVERAGE: 3.25 VOTITALY_OUTOF)
Tips and Tricks - Formule

Attraverso MATR.SOMMA.PRODOTTO() possiamo sommare al volo una serie di dati impostando più di una condizione. Con SOMMA.SE() è diverso.

 

Per sommare con SOMMA.SE tutte le celle della colonna A dove nelle stesse righe ma in colonna B il Centro di Costo è uguale a "120" e nella colonna C il Conto è uguale a "65500" dovremo necessariamente creare un'altra colonna (per esempio in D) che concateni il contenuto della colonna C e D. SOMMA.SE eseguirà l'analisi su questa colonna. La funzione a quel punto sarà:

=SOMMA.SE(D:D; "=12065500"; A:A)

 

Con MATR.SOMMA.PRODOTTO, è molto più veloce anche se il passaggio è un po' più complesso.

=MATR.SOMMA.PRODOTTO((A1:A100)*(B1:B100=120)*(C1:C100=65500))

 

La formula funziona perché gli argomenti (B1:B100=120)(C1:C100=65500) generano degli 0 e 1 che, moltiplicati tra loro, restituiscono la cifra contenuta in colonna A solo quando entrambi sono uguali a 1, cioé quando contengono proprio 120 e 65500.

 

Questa funzione è molto utile perché si possono aggiungere molte condizioni con gli operatori maggiore, maggiore o uguale, minore, minore o uguale o diverso. Il limite è che occorre definire sempre con cura il range e non ci si può permettere di indicare genericamente la colonna (es. B:B=120). Infine, se nel range di somma (nel nostro esempio la colonna A) è presente un valore non numerico, la formula restituisce #VALORE!