| 
Login
Formato Ora negativo
(3 voti, media: 3.00 di 5)
Tips and Tricks - F.A.Q.

D: E' possibile rappresentare con un formato speciale un saldo ore negativo (per esempio, nel formato hh.mm.ss, 35.23.04 meno 37.23.01)?

R: Un'ora negativa, purtroppo, per Excel è un concetto molto ostico.

E' necessario rappresentare le ore SEMPRE in positivo, usando magari una formula che analizza se un valore è superiore all'altro.

 

In questo senso, si può usare una formula un po' complessa che combini le funzioni TESTO(), ASS() e SE() e CONCATENA abbreviato (simbolo "&").

Per maggiori dettagli, fare riferimento a un manuale di Excel o alla guida online.

 

Immaginiamo che in A1 ci sia un'ora e in A2 un'altra.

La formula in A3 potrebbe essere:

=SE(A1-A2<0;"-"&TESTO(ASS(A1-A2);"hh.mm.ss");TESTO((A1-A2);"hh.mm.ss"))

 

NB: il risultato potrà essere usato solo come testo e non come numero, quindi nessuna operazione matematica.

A livello generale, invece, il risultato che si ottiene dalla semplice sottrazione è riutilizzabile come numero in altre formule.