| 
Login
Eliminare i doppioni da una lista
(14 VOTITALY_VOTES, VOTITALY_AVERAGE: 2.43 VOTITALY_OUTOF)
Tips and Tricks - F.A.Q.

D: E' possibile, tramite un comando Excel, eliminare le righe doppie?

R: Se una riga è davvero doppia significa che l'unione dei testi dei diversi campi deve essere uguale all'unione dei testi di un'altra riga.

Il problema si risolve come segue:

  1. in una nuova colonna, per esempio X, concatenare tutti i campi (usando, per es, =A1&B1&C1 ecc.) e copiare la funzione fino all'ultima riga presente
  2. usare la funzione CONTA.SE() per contare quante celle della colonna appena creata (X) sono uguali alla cella in cui viene posizionata la funzione stessa. In altre parole, nella cella Z3 scriveremo =SOMMA.SE(X:X; X3). Copiare la funzione fino all'ultima riga
  3. sulla colonna appena creata (es. Z) creata filtrare tutte le celle maggiori di 1 e cancellarle

Marco propone una variante:

Se vogliamo eliminare i doppioni nella colonna A, occorrerà posiszionarsi in una colonna libera (es B) e nella prima cella dell'intervallo (es. B1) e digitare

=CONFRONTA(A1; A2; 0).

Trascinando la funzione su tutto l'intervallo utile otterremo 1 in corrispondenza delle celle doppie. A questo punto basterà eliminare le righe con gli 1