|
Login

TOPIC: Calcolo presenze e sviluppo

Calcolo presenze e sviluppo 10 years 1 month ago #1473

  • mwalter
  • mwalter's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 18
  • Karma: 0
Sono approdato al Vostro forum per chiedere aiuto relativamente lo sviluppo di una tabella per il calcolo delle presenze e seguente sviluppo busta paga. Ho modificato un progetto che ho trovato online relativamente le specificità del contratto di categoria che mi interessa e sto avendo difficoltà in alcuni sviluppi per i quali so appunto qui, Grazie a tutti coloro vorranno aiutarmi. Elenco i problemi nell’ordine che dovrei risolvere nel file allegato:
• Ho verificato che per alcuni intervalli di orario la colonna mancato pasto non mi sviluppa il giusto risultato, e sono
Colonna Uscita G H Entrata
12.0 14.00
13.0 15.00
16.0 18.00
18.0 20.00
21.0 23.00

Nella colonna mancato pasto dovrei ottenere il risultato di 1 ogni qual volta l’orario di uscita della prima fascia ha un intervallo relativamente l’orario di entrata della seconda fascia inferiore o uguale a 2 ore oppure se facendo in seconda fascia un orario unico che si sviluppa da un orario di entrata dopo le ore 18.00, mentre erroneamente mi da risultato solo per la prima fascia.
Spero di essere stato chiaro, attendo gentilmente Vostro aiuto grazie per la collaborazione, alla quale credo ricorrerò prima del termine di questo programma

Attachment presenze_gennaio.xls not found

Attachments:
The administrator has disabled public write access.

Re:Calcolo presenze e sviluppo 10 years 1 month ago #1474

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao, ho messo in R8

=SE(E(O(E8="Lavoro";E8="Sett. Corta";E8="7° giorno";E8="Missione";E8="Festivo L.";E8="Trasferta");O(H8>=0,75;H8-G8<=2/24);H8-G8<>0);1;"")

Nella formula da testare: 0,75=18/24=18:00 2/24=2 ore=2:00.

Spero sia d'aiuto
The administrator has disabled public write access.

Re:Calcolo presenze e sviluppo 10 years 1 month ago #1479

  • mwalter
  • mwalter's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 18
  • Karma: 0
In primis, grazie per la collaborazione, purtroppo non soddisfa le mie necessità, spiego brevemente cosa dovrebbe fare la formula da inserire, se la prestazione lavorativa si sviluppa in due fasce orarie mattino e pomeriggio, pomeriggio e sera, e tra le due prestazioni l’intervallo è minore o uguale a 2, oppure se la prestazione è unica ed inizia dalle 18.00 in poi bisogna attribuire 1 per la colonna R8 (mancato pasto), ed inoltre, non so se hai verificato, vi sono quegli intervalli che ho indicato per i quali ciò non avviene.
GRAZIE sempre per la cortese disponibilità.
Walter
The administrator has disabled public write access.

Re:Calcolo presenze e sviluppo 10 years 1 month ago #1480

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao, ti allego il file dove ho valorato.

Nella formula ho rimesso il riferimento a B42 (le due ore).
Ho copiato il foglio di gennaio dove ho aggiunto una colonna per fare le prove di correzione.
Mi puoi evidenziare i casi dove non funziona; cerco di sistemare la formula:ci provo.

Edit: nel foglio Test ho copiato nella cella B42, incollandola come valore, la differenza =h15-g15 (2 ore). Attenzione: la differenza viene approssimata come 0,0833333333333334, mentre 2:00 diventa 0,0833333333333333. Non sono due numeri perfettamente uguali.


Saluti

File Attachment:

File Name: test-20100607.xls
File Size: 252416
Attachments:
Last Edit: 10 years 1 month ago by Canapone. Reason: saltata corrente
The administrator has disabled public write access.

Re:Calcolo presenze e sviluppo 10 years 1 month ago #1486

  • mwalter
  • mwalter's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 18
  • Karma: 0
Carissimo grazie per la gentilezza, in effetti sembra funzionare l'unico problema che rimane è che nel calcolo dovrei escludere la casistica a turno unico mattina dove inserendo entrata 08.00 uscita 14.00, per esempio, mi da risultato 1 per il mancato pasto.Non ho potuto reinviarti il file con esempi, perchè non so come allegarlo.
Grazie Walter
The administrator has disabled public write access.

Re:Calcolo presenze e sviluppo 10 years 1 month ago #1487

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao, dovrebbe bastare levare il < da H8-G8<>0.

=SE(E(O(E8="Lavoro";E8="Sett. Corta";E8="7° giorno";E8="Missione";E8="Festivo L.";E8="Trasferta");O(H8>=0,75;H8-G8<=$B$42);H8-G8>0);1;"")

Attenzione sempre a cosa hai parcheggiato in B42.

Saluti
The administrator has disabled public write access.
Time to create page: 0.622 seconds