|
Login
  • Page:
  • 1

TOPIC: RICERCA IN LISTA POSIZIONANDO IL CURSORE

RICERCA IN LISTA POSIZIONANDO IL CURSORE 8 years 1 month ago #8139

  • fuciletto
  • fuciletto's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • Karma: -2
Ho un problema di programmazione che non so risolvere perché non conosco il VB.

Ho un elenco di nomi a cui sono associate altre informazione, la classica riga con nome cognome, indirizzo, ... In più, nella cella più a sinistra,c'è un numero di riferimento che cambia di anno in anno.

Vorrei predisporre una ricerca in cima alla lista, in modo che scrivendo nome e cognome o solo cognome, il cursore si vada a posizionare sulla cella del nuovo numero di riferimento relativo al nome digitato.
Una sorta di combinazione tra "cerca.vert" e "vai a".

Ho cercato anche di capire se si potesse usare solo "vai a", ma non sono riuscito; pensavo fare qualcosa tipo scrivere il nome nella ricerca e poi, con F5, selezionare la cella del nome scritto.

Allego un file di esempio.
Nel file, scrivendo il cognome nella colonna C3 (o cognome+nome in C3+D3), dovrebbe poi venire automaticamente selezionata la prima cella nella riga corrispondente alla persona cercata (in caso di cognomi uguali, va bene anche selezionare il primo), in modo da poterci direttamente scrivere dentro il nuovo riferimento.

Spero di essermi spiegato abbastanza.

grazie

File Attachment:

File Name: CERCAVERTSPOSTA.xlsx
File Size: 8 KB
The administrator has disabled public write access.

RICERCA IN LISTA POSIZIONANDO IL CURSORE 8 years 1 month ago #8149

  • mauro27
  • mauro27's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 636
  • Thank you received: 9
  • Karma: 42
ciao

uso qualcosa di simile per la mia rubrica, dove

cognome e nella stessa riga dei cognomi, cosi' se non hai celle vuote (io metto dei "." )
puoi avere il riempimento automatico

aggiungi una colonna che ti dia la riga da cercare
=+SE(D11>=$D$3;RIF.RIGA();"")
poi prendi quelle di valore inferiore


Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Range("D3")) Is Nothing Then
Range("D" & Range("f3").Value).Select
End If
End Sub

vedi allegato

ciao
Attachments:
mauro27 - excel 2010 su Win7 - excel 2011 su Mac
_________________________________________________
"per ogni problema esistono almeno 3 soluzioni, l'importante è trovare quella più semplice" - Mauro
"Ogni problema ha tre soluzioni: la mia soluzione, la tua soluzione, e la soluzione giusta" -...
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.420 seconds