|
Login
  • Page:
  • 1

TOPIC: valori positivi e negativi in colonna.....

valori positivi e negativi in colonna..... 3 years 9 months ago #10432

  • jul
  • jul's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 14
  • Karma: -1
Buona sera, ho il problema di riconoscere alcuni dati su una colonna, vorrei fare una formula o vba per fare trascinamento dopo aver impostato la prima cella
mi spiego meglio; su una colonna ( es colonna A) ho dei numeri positivi, negativi e degli zeri
nella colonna successiva B vorrei che adiacente al numero positivo mi desse il risultato tra esso e il numero negativo precedente, considerando il fatto che il numero negativo precedente si può trovare in qualsiasi posizione ,1 cella sopra o 2-3-4 celle sopra, nell'intervallo ci sono gli zeri
ovviamente posso farlo manualmente, ma data la mole di dati serve un sacco di tempo e la possibilità di sbagliare

dovrebbe essere come in questo esempio: (il trattino stà indicare la colonna adiacente)
-12-0
0-0
0-0
15-3
0-0
0-0
0-0
-8-0
0-0
0-0
10-2

nella speranza di essere stato abbastanza chiaro, se qualcuno gentilmente potesse darmi un aiutino lo ringrazio anticipatamente
Last Edit: 3 years 9 months ago by jul.
The administrator has disabled public write access.

valori positivi e negativi in colonna..... 3 years 9 months ago #10433

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,


In A2 il primo numero:


=SE(A2>0;A2+SE.ERRORE(CERCA(2;1/(A1:A$2<0);$A1:A$2);0);0)


Dalla descrizione che hai fatto sembra che accanto ai numeri negativi ed agli zero sia richiesto uno uno zero.

Meglio allegare un piccolo file la prossima volta per l'aiutino.

Saluti
Last Edit: 3 years 9 months ago by Canapone.
The administrator has disabled public write access.

valori positivi e negativi in colonna..... 3 years 9 months ago #10434

  • jul
  • jul's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 14
  • Karma: -1
Canapone wrote:
Ciao,


In A2 il primo numero:


=SE(A2>0;A2+SE.ERRORE(CERCA(2;1/(A1:A$2<0);$A1:A$2);0);0)


Dalla descrizione che hai fatto sembra che accanto ai numeri negativi ed agli zero sia richiesto uno uno zero.

Meglio allegare un piccolo file la prossima volta per l'aiutino.

Saluti

Ciao canapone, si questa è proprio la formula che cercavo
mille ringraziamenti x la tua gentilezza e disponibilità
PS.
Meglio allegare un piccolo file la prossima volta per l'aiutino.
scusami, la prossima volta devo ricordarmelo
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.498 seconds