|
Login

TOPIC: Estrarre dati da un foglio di lavro

Estrarre dati da un foglio di lavro 9 years 8 months ago #2491

  • Angelica
  • Angelica's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 45
  • Karma: 0
Ciao a atutti,
ho un problema di qs genere: dal gestionale di contabilità faccio delle estrazione in formato excel per fare dei controlli.
Parto da un foglio base e vorrei estrarre solo i dati che mi interessano ovviamnete dando dei criteri.
Purtroppo da sola non riesco a farlo, potete darmi una mano? E' molto importante e urgente
Ho alleagto il file nel caso possiamo parlarne insieme.
Grazie mille.
Ciao
Dona
Attachments:
Last Edit: 9 years 8 months ago by admin.
The administrator has disabled public write access.

Re:Estrarre dati da un foglio di lavro 9 years 8 months ago #2492

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

guarda se le formule in verdolino (MATR.SOMMA.PRODOTTO) fanno il caso tuo.
Se cambi i "Con" vedrai che cambiano i numeri.
Lo stesso risultato lo ottieni con le pivot.

Spero sia d'aiuto

Buona giornata
Attachments:
Last Edit: 9 years 8 months ago by Canapone.
The administrator has disabled public write access.

Re:Estrarre dati da un foglio di lavro 9 years 8 months ago #2493

  • Angelica
  • Angelica's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 45
  • Karma: 0
ciao,
ti ringrazio ma il problema è un'altro.
Nel primo foglio "DATA BASE" ho una serie di dati che arrivano direttamente dal sof di contabilità.
Tutti gli altri fogli che vedi gli ho creati io manualmente devidendoli per il cretierio COLONNA K del date base.
Io quello lo vorrei fare in automatico in quanto qs file rispetto a quello dove dovo lavorare è una miscuola parte.
Ciao e grazie
Dona
The administrator has disabled public write access.

Re:Estrarre dati da un foglio di lavro 9 years 8 months ago #2494

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

credo che qui hai bisogno di qualcuno che conosca il vba (che purtoppo non conosco).

Un problema simile in ufficio lo gestisco in parte per i valori numerici (se voglio un foglio per Con) con il comando mostra pagine una volta impostata la tabella pivot. Non so se le sai usare.

Non vorrei farti confusione: mi sembra che hai fretta.

Spero che qualche amico del forum intervenga.
Last Edit: 9 years 8 months ago by Canapone.
The administrator has disabled public write access.

Re:Estrarre dati da un foglio di lavro 9 years 8 months ago #2495

  • Angelica
  • Angelica's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 45
  • Karma: 0
la fretta è relativa.
Grazie cmq.
Ciao
Dona
The administrator has disabled public write access.

Re:Estrarre dati da un foglio di lavro 9 years 8 months ago #2496

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

fai una prova nel foglio "formule".

basta copiare cosa cerchi in A1 (evdidenziata in un bel giallo). Il risultato lo puoi incollare nei vari fogli con copia incolla valori. Sono tutte formule matriciali del tipo che pescano nelle colonne del database (ho levato lo spazio dal nome del foglio)

=SE(RIGHE($A$2:$A2)<=CONTA.SE(DATABASE!$K$2:$K$1000;$A$1);INDICE(DATABASE!A$2:A$1000;PICCOLO(SE(DATABASE!$K$2:K$1000=$A$1;RIF.RIGA(DATABASE!$K$2:$K$1000)-1);RIGHE($A$2:$A2)));"")

Ripeto il vba è molto più efficiente.

Spero sia d'aiuto

Saluti

Edit: non riesco ad allegare il file: non ho WINZIP sul PC.

Provo stasera da casa
Last Edit: 9 years 8 months ago by Canapone. Reason: winzip
The administrator has disabled public write access.
Time to create page: 0.472 seconds