|
Login
  • Page:
  • 1
  • 2

TOPIC: formula somma.se applicata a dati con filtro

formula somma.se applicata a dati con filtro 7 years 11 months ago #8285

Buongiorno a tutti, mi sono appena iscritta al forum e colgo l'occasione per salutarvi.
Ho cercato nei post una soluzione al mio problema ma non ho trovato niente di adatto al mio caso.
Ho bisogno gentilmente un aiuto al mio problema, ho un foglio Excel con i seguenti dati:

A B C D E
1 ripartizione bonifico cod tributi anno accredito
2 01/01/2014 01/01/2014 3918 2013 € 150,00
3 02/01/2014 01/01/2014 3918 2013 € 160,00
4 03/01/2014 02/02/2014 3906 2013 € 170,00
5 04/01/2014 02/02/2014 3906 2013 € 520,00
6 05/01/2014 02/02/2014 3914 2012 € 235,00
7 06/01/2014 03/03/2014 3924 2012 € 245,00
8 01/01/2014 01/01/2014 3918 2013 € 150,00
9 02/01/2014 01/01/2014 3918 2013 € 160,00
10 03/01/2014 02/02/2014 3906 2013 € 170,00

io ho bisogno di sommare tutti gli accrediti ricevuti in base al codice tributi - (ho usato la funzione somma.se ma il problema è che devo però filtrare tutto anche in base alla data di ripartizione/bonifico. ho visto che la funziona somma.se applicata a dati con filtro non funziona in quanto la somma non tiene conto dei filtri. Avrei bisogno di una formula a metà tra somma.se e subtotale.) di modo che, dopo che ho filtrato i dati in base alla data di accredito, mi sommi gli importi in base al codice tributi.

Spero di essermi spiegata bene. (l'esempio che ho riportato è solo una piccola parte dell'elenco in quanto devo rendicontare tutti gli accredito dell'anno 2013 e le righe del foglio Excel sono circa 8.000..... help).

Grazie per gli eventuali aiuti..... ciao
Laura
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 7 years 11 months ago #8286

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

provo ad aiutarti, meglio allegare un piccolo file d'esempio


La formula che dovresti usare, ammesso che i numeri siano nella colonna E, i codici numerici nella colonna C.

Supponiamo che tu abbia filtrato già una data, la formula

=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(E3:E1000;RIF.RIGA(A3:A1000)-MIN(RIF.RIGA(A3:A1000));;1));--(C3:C1000=3918))

somma i valori della colonna E corrispondenti a 3918 ("3918" se fosse alfanumerico)

Saluti
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 7 years 11 months ago #8287

Ciao Canapone, grazie 10000000000 per l'aiuto... funzionaaaa!!!!!! :laugh: :woohoo: :woohoo:
sono felicissima, non sai quanto tempo di lavoro mi hai fatto risparmiare......

ho adattato la tua formula al mio elenco (i numeri li ho nella colonna m e il codice numerico nella colonna j)e ho aumentato tutte le somme fino alla colonna 10000. Di conseguenza:

=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(M3:M10000;RIF.RIGA(A3:A10000)-MIN(RIF.RIGA(A3:A10000));;1));--(J3:J10000=3918))

Un ultimo aiuto (anche se non riesci fa niente visto che già mi hai dato un enorme aiuto)...

E' possibile aggiungere nelle condizione anche la colonna anno (ovvero che mi sommi tutti i cod. 3918 dell'anno 2012??)

Per ora grazie veramente di cuore!!!!!!!

ps ma il file di esempio dovevo allegarlo io o l'hai allegato te?? dove?? :blink:
Last Edit: 7 years 11 months ago by luthien1980.
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 7 years 11 months ago #8288

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

supponiamo che Anno sia un campo numerico nella colonna B, basta aggiungere la nuova condizione --(B3:B1000=2012) oppure --(B3:B1000="2012")

=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(E3:E1000;RIF.RIGA(A3:A1000)-MIN(RIF.RIGA(A3:E1000));;1));--(C3:C1000=3918);--(B3:B1000=2012))

Mi fa piacere che tu sia stata capace di adattare la formula. Puoi aggiungere in coda alla formula altre condizioni se servissero.


Altro argomento: in basso trovi "Add file" che ti permette di allegare file di piccole dimensioni.

Saluti
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 7 years 11 months ago #8289

Perfetto, quindi per aggiungere nuove condizioni basta che aggiungo alla fine:

;--(cellainizio:cellafine=condizione) sistemando le varie parentesi..

beh che dire, grazie 100000000 Canapone!! da sola proprio non ci sarei mai arrivata!!!!
Sono felicissima :laugh: :laugh: :laugh:

Tanto tanto lavoro in meno considerando che fino ad ora ho sommato quasi tutto a mano (filtrando tutti i codici e poi subtotale)... adesso mi basta cambiare le date e ho tutti in automatico...che meraviglia!!

Grazie di cuore per l'aiuto, ora stampo questo topic e lo appendo in bacheca!!!!

Buona giornata
Laura
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 7 years 11 months ago #8290

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

la formula con due o più condizioni credo tu possa declinarla anche così

=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(E3:E1000;RIF.RIGA(A3:A1000)-MIN(RIF.RIGA(A3:E1000));;1));(C3:C1000=3918)*(B3:B1000=2012))

le condizioni le aggiungi con ... *(nuova condizione)

Grazie a te del riscontro.

Saluti
Last Edit: 7 years 11 months ago by Canapone.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.365 seconds