|
Login
  • Page:
  • 1
  • 2

TOPIC: formula somma.se applicata a dati con filtro

formula somma.se applicata a dati con filtro 5 years 9 months ago #10518

Ciao a tutti.
Scusate se riapro questo topic...

Sto lavorando ad un file nel quale ho inserito, nelle celle iniziali del foglio, la presente formula:

=SOMMA.SE($D$6:$D$2999;DATI!$F$4;$AW$6:$AW$2999)+SOMMA.SE($D$6:$D$2999;DATI!$F$5;$K$6:$K$2999)+SOMMA.SE($D$6:$D$2999;DATI!$F$2;$K$6:$K$2999)+SOMMA.SE($D$6:$D$2999;DATI!$F$3;$K$6:$K$2999)

Purtroppo, se filtro il foglio, il dato estratto rimane invariato.
Mi servirebbe capire come fare a far si che, quella formula, si comporti come se si applicasse un SUBTOTALE...

Ho letto che si potrebbe applicare MATR.SOMMA.PRODOTTO.
Qualcuno sa come poter modificare la formula per farla funzionare?
Grazie davvero a tutti!
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 5 years 9 months ago #10519

  • Paperino
  • Paperino's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 67
  • Thank you received: 8
  • Karma: 6
Ciao,

riprendo la formula di Canapone (ciao fiorentino)
=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO($AW$6:$AW$2999;RIF.RIGA(A$6:A$2999)-MIN(RIF.RIGA(A$6:A$2999));;1));--($D$6:$D$2999=DATI!$F$4))+MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO($AW$6:$AW$2999;RIF.RIGA(A$6:A$2999)-MIN(RIF.RIGA(A$6:A$2999));;1));--($D$6:$D$2999=DATI!$F$5))+MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO($AW$6:$AW$2999;RIF.RIGA(A$6:A$2999)-MIN(RIF.RIGA(A6:A2999));;1));--($D$6:$D$2999=DATI!$F$2))+MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO($AW$6:$AW$2999;RIF.RIGA(A$6:A$2999)-MIN(RIF.RIGA(A6:A2999));;1));--($D$6:$D$2999=DATI!$F$3))

Essendo la formula molto complicata avrei bisogno di un piccolo esempio per aggiustarla e per controllare se i vari elementi sono tarati bene.

Posso essermi sbagliata con qualche parentesi :(
Last Edit: 5 years 9 months ago by Paperino.
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 5 years 9 months ago #10520

FANTASTICOOOOOOOOOOOOOOOOOOOOO :-) :-) :-)
Applausci a scena aperta... :-)

Visto che sono anni che sto cercando di acpire come funziona MATR.SOMMA.PRODOTTO, posso chiederti se mi dai una dritta?
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 5 years 9 months ago #10521

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

qui trovi qualche spiegazione sulla formula:

www.pc-facile.com/forum/viewtopic.php?t=95095

www.riolab.org/index.php?option= ... &itemid=68

Per matr.somma.prodotto partirei dai chiarissimi video di Gerardo, esempio:

www.youtube.com/watch?v=4ApRuQ939yM

www.youtube.com/watch?v=iHjan0h4OUQ

Ne approfitto per salutare Paperino.
Last Edit: 5 years 9 months ago by Canapone.
The administrator has disabled public write access.

formula somma.se applicata a dati con filtro 5 years 8 months ago #10524

Grazie mille a tutti!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.366 seconds