|
Login
  • Page:
  • 1

TOPIC: Utilizzo nomi file dinamici

Utilizzo nomi file dinamici 6 years 3 months ago #8966

  • pava1955
  • pava1955's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 10
  • Karma: 0
:)
Buonasera !
pongo una questione che certamente, grazie alla vostra comprovata professionalità, riuscirete a risolvere.
all'interno di una formula faccio riferimento ai dati di una cella di un file esterno.
(es della formula utilizzata:
=SE('\\NAS\Disco\Pianificazione\[Agosto_2014.xlsx]Materiale'!$F4=0;D4-(P4+Q4+R4+S4);'\\NAS\Disco\Pianificazione\[Agosto_2014.xlsx]Materiale'!$F4-(P4+Q4+R4+S4))

Vorrei sapere se è possibile rendere "dinamica" la formula e poter gestire il nome del file utilizzando il contenuto di una cella e/o un nome nell'ambito della "Gestione nomi".
Ad esempio per utilizzare il nome file Settembre_2014 ecc.

Grazie per il Vs interessamento
The administrator has disabled public write access.

Utilizzo nomi file dinamici 6 years 2 months ago #9041

  • Grograman
  • Grograman's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Supponendo tu abbia:
A1 = Percorso (\\NAS\Disco\Pianificazione\)
A2 = File (Agosto_2014.xlsx)
A3 = Foglio (Materiale)
A4 = Cella (F4)

Puoi costruire la formula con la funzione "INDIRETTO":
=SE(INDIRETTO("'"&A1&"["&A2&"]"&A3&"'!"&A4;1)=0;D4-(P4+Q4+R4+S4);INDIRETTO("'"&A1&"["&A2&"]"&A3&"'!"&A4;1)-(P4+Q4+R4+S4))
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.560 seconds