|
Login
  • Page:
  • 1

TOPIC: confronto valori celle tra due fogli di lavoro

confronto valori celle tra due fogli di lavoro 7 years 2 months ago #9281

  • mates
  • mates's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: -4
Salve
sono un neofita, avrei bisogno di confrontare le 2 celle del "foglio 1" contenute nelle colonne cognome e nome con le corrispondenti celle delle colonne del "foglio 2" che se trovate, scrivere su una cella "x" della stessa riga del "foglio 1" -presente-, se non trovato ripetere tale operazione per tutte le celle cognomi e nomi delle colonne contenuti nel "foglio 1".
Grazie
Mates
The administrator has disabled public write access.

confronto valori celle tra due fogli di lavoro 7 years 2 months ago #9282

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

potresti provare in C2 accanto al primo nome (A2) e cognome (B2)

=SE(MATR.SOMMA.PRODOTTO(--(Foglio2!A$2:A$100&Foglio2!B$2:B$100=A2&B2));"X";"")

copiando la formula in basso ottieni delle x accanto ai nominativi presenti

Se non ho capito allega un piccolo file d'Excel con qualche esempio.

Saluti
Last Edit: 7 years 2 months ago by Canapone.
The administrator has disabled public write access.
The following user(s) said Thank You: Paperino

confronto valori celle tra due fogli di lavoro 7 years 2 months ago #9286

  • mates
  • mates's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: -4
Salve forse non ho esposto bene il problema pertanto allego un file di esempio nel quale nel foglio 1, nelle celle delle colonne A e B sono elencati rispettivamente cognomi e nomi degi utenti e nelle celle della colonna C il risultato cioè "PRESENTE" dopo averne verificato la presenza nel foglio 2 dove sono elencati nelle celle delle colonne A e B rispettivamente cognome e nome degli utenti realmente presenti.
Manualmente verifico che se ad esempio l'utente Tizio Aldo del foglio 1 è presente anche nel foglio 2 scrivo PRESENTE nella stessa riga alla colonna C del foglio 1, se non è presente non scrivo niente e ripeto la stessa verifica per gli utenti successivi.
Come fare per rendere automatica questa operazione?
Utilizzo excel 2010
Grazie
Mates
Attachments:
The administrator has disabled public write access.

confronto valori celle tra due fogli di lavoro 7 years 2 months ago #9287

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,


sostituisci nella formula la X con PRESENTE.

=SE(MATR.SOMMA.PRODOTTO(--(Foglio2!A$2:A$100&Foglio2!B$2:B$100=A2&B2));"PRESENTE";"")

copia la formula nel foglio1 in C2 e da C2 in C3:C14.

Saluti
Last Edit: 7 years 2 months ago by Canapone.
The administrator has disabled public write access.
The following user(s) said Thank You: mates
  • Page:
  • 1
Time to create page: 0.356 seconds