|
Login
  • Page:
  • 1

TOPIC: Pivot Valore inizio mese

Pivot Valore inizio mese 6 years 6 months ago #9967

  • Fiore
  • Fiore's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Karma: 0
Buongiorno a tutti,
In una tabella pivot si possono calcolare in colonna i valori inizio mese e fine mese
mettiamo che i dati foglio excel in centinaia di righe sono

Data Nome Q.ta Saldo
02/06/2015 Pippo 60 50282
02/06/2015 Pluto 30 145006
02/06/2015 Pippo 50 118911
02/06/2015 Pippo 52 113042
02/06/2015 Pluto 40 210152
02/06/2015 paperino 60
02/06/2015 Pluto 40 188857
02/06/2015 Pippo 12 141044
02/06/2015 Pluto 40 189863
02/06/2015 Pippo 52 52850
03/06/2015 Pluto 100 50462
03/06/2015 Pippo 50 377927
03/06/2015 Pluto 50 288190
03/06/2015 paperino 30 0
04/06/2015 Pluto 100 55462
04/06/2015 Pippo 50 382927
04/06/2015 Pluto 50 293190
04/06/2015 paperino 30 0
Tabella Pivot i dati dovrebbero essere
Row TotQ.ta Inizio Fine mese
paperino120 0 0
Pippo 326 50282 382927
Pluto 450 145006 293190

grazie per l'aiuto
The administrator has disabled public write access.

Pivot Valore inizio mese 6 years 6 months ago #9971

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

non mi sembra che le pivot possano aiutarti.

Credo tu debba servirti di colonne di servizio nel database che riportino per mese e nome i saldi iniziali e finali.

Saluti
The administrator has disabled public write access.

Pivot Valore inizio mese 6 years 6 months ago #9972

  • Fiore
  • Fiore's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Karma: 0
Ciao,

Come posso fare per cercare in automatico i saldi iniziali e finali ogni mese?

Grazie
The administrator has disabled public write access.

Pivot Valore inizio mese 6 years 6 months ago #9973

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

qualcosa di simile: primo saldo per mese e nome
=INDICE(D$2:D$100;CONFRONTA(MESE(A2)&B2;INDICE(MESE(A$2:A$100)&B$2:B$100;0);0))

ultimo saldo
=CERCA(2;1/(MESE($A$2:A$100)&B$2:B$100=MESE(A2)&B2);D$2:D$100)

Saluti
Last Edit: 6 years 6 months ago by Canapone.
The administrator has disabled public write access.

Pivot Valore inizio mese 6 years 6 months ago #9978

  • Fiore
  • Fiore's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Karma: 0
Ciao,

Ti ringrazio tantissimo
La prima formula restituisce il primo valore del mese per ciascun nome e la seconda formula restituisce l'ultimo valore, anche se non ho capito quest'ultima come funziona.

Saluti
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.428 seconds