|
Login

TOPIC: Trova il costo di acquisto da una scala prezzi

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10126

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao

meglio così

=SE(CONTA.PIÙ.SE($A$2:$A$17;D23;$B$2:$B$17;D22);INDICE(E2:E17;CONFRONTA(D22&D23&MIN(SE(B2:B17=D22;SE(A2:A17=D23;ASS(D2:D17-D21))));B2:B17&A2:A17&ASS(D2:D17-D21);0));"")

sempre matriciale.

Mi sono perso nella mia materia :(
Attachments:
Last Edit: 6 years 3 months ago by Canapone.
The administrator has disabled public write access.
The following user(s) said Thank You: marcalza

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10132

  • Paperino
  • Paperino's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 67
  • Thank you received: 8
  • Karma: 6
Ciao a tutti,

@Canapone: mi puoi spiegare la formula, quando trovi un minuto?

:)
The administrator has disabled public write access.

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10133

  • marcalza
  • marcalza's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 13
  • Karma: 0
Purtroppo non restituisce il valore corretto...
#VALORE

non saprei....
Grazie comunque!
Marco
The administrator has disabled public write access.

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10134

  • Paperino
  • Paperino's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 67
  • Thank you received: 8
  • Karma: 6
Ciao a tutti,


provo a rispondere al posto di Canapone.

La formula deve essere copiata e riconfermata tenendo premuti control+maiusc+invio: se questa operazione viene fatta correttamente la formula appare fra due parentesi graffe (come vedo nell'esempio allegato da Canap.).

buonga giornata
Last Edit: 6 years 3 months ago by Paperino.
The administrator has disabled public write access.

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10135

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

confermo (e saluto) quanto scritto da Paperino.

Forse la formula non è stata confermata con il control+maiusc+invio.

Può anche essere che mi sfugga qualcos'altro.

Se avessi ancora problemi puoi riallegare un piccolo esempio?

Saluti


@Paperino: scusa ho visto solo ora la tua richiesta. Mi ci vuole un po' per scrivere, appena posso rispondo. Sperando che la formula funzioni...
Attachments:
Last Edit: 6 years 3 months ago by Canapone.
The administrator has disabled public write access.
The following user(s) said Thank You: marcalza

Trova il costo di acquisto da una scala prezzi 6 years 3 months ago #10136

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao di nuovo,

stessa formula, senza che sia necessario lo sato matriciale.

Copiando in D24


=SE(CONTA.PIÙ.SE($A$2:$A$17;D23;$B$2:$B$17;D22);INDICE(E2:E17;CONFRONTA(D22&D23&PICCOLO(INDICE((B2:B17=D22)*(A2:A17=D23)*ASS(D2:D17-D21); );MATR.SOMMA.PRODOTTO(--(B2:B17&A2:A17<>D22&D23))+1);INDICE(B2:B17&A2:A17&ASS(D2:D17-D21); ); 0));"")

la formula dovrebbe fare il proprio lavoro.

Saluti

Ho allegato il file con la formula.
Attachments:
Last Edit: 6 years 3 months ago by Canapone.
The administrator has disabled public write access.
The following user(s) said Thank You: marcalza
Time to create page: 0.324 seconds