|
Login
  • Page:
  • 1

TOPIC: celle a valore dinamico

celle a valore dinamico 5 years 5 months ago #10668

  • Gerryman74
  • Gerryman74's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 48
  • Karma: -6
Ciao a tutti,
ho necessità di replicare n volte il cerca verticale sulla base del valore n contenuto in altra cella, valore che ovviamente puo' cambiare e che quindi mi fa necessitare di una formula dinamica laddove utilizzavo una formula manuale come riportato nel file di esempio che ho allegato
grazie
gerry
Attachments:
The administrator has disabled public write access.

celle a valore dinamico 5 years 5 months ago #10675

  • Marius44
  • Marius44's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 185
  • Thank you received: 38
  • Karma: 14
Ciao Gerry

Non chiedermi che ragionamento ho fatto perchè non saprei spiegartelo!! :huh:
metti in J7 la seguente formula (Matriciale = Ctrl+Shift+Invio)
=SOMMA($B$7:$B$150*SE($A$7:$A$150>=$F7;1;0)*SE($A$7:$A$150<=$F7+2;1;0))
e in K7 laseguente formula (Matriciale = Ctrl+Shift+Invio)
=SOMMA($B$7:$B$150*SE($A$7:$A$150>=$F7;1;0)*SE($A$7:$A$150<=$F7+3;1;0))
poi seleziona entrambe le celle e tira giù per copiare fin dove serve

Allego, comunque, il tuo file con, in giallo, quello che ho fatto.
Prova e fai sapere. Ciao,
Mario

File Attachment:

File Name: Cartel1_2016-07-26_Marius.xlsx
File Size: 14 KB
The administrator has disabled public write access.
The following user(s) said Thank You: Gerryman74

celle a valore dinamico 5 years 5 months ago #10676

  • Marius44
  • Marius44's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 185
  • Thank you received: 38
  • Karma: 14
Ciao Gerry
Beh, una minima spiegazione a te e agli amici del Forum la devo.

Il ragionamento che ho fatto mi è venuto in mente guardando la Guida di Excel in merito alla funzione INDICE nella parte che riguarda Riferimento.
L’ultime esempio recita: =SOMMA(B2:INDICE(A2:C6;5;2)) La somma dell'intervallo che ha inizio in B2 e termina all'intersezione della quinta riga e della seconda colonna dell'intervallo A2:A6, ossia la somma di B2:B6. (2,42)
Quindi, ho pensato, se indico l’intervallo con cui confrontare la data e, se questo valore rientra nei parametri voluti, lo moltiplico per il valore di una condizione SE(TEST,VERO,FALSO) il gioco è fatto. Ovviamente il tutto sotto forma matriciale (Ctrl+Shift+Invio).

Adesso, a mente serena, è stato abbastanza facile descrivere il procedimento ma ti/vi assicuro che, per me che non sono affatto un esperto di formule, è stata un’impresa.

Ora mi aspetto un giudizio dei miei Maestri (Scossa/Canapone) ed anche una formula col cavallo di battaglia di Stefano (ma anche di ninai): MATR.SOMMA.PRODOTTO. Io ci ho provato ma con risultati deludenti.

Ciao a tutti,
Mario
The administrator has disabled public write access.
The following user(s) said Thank You: Gerryman74

celle a valore dinamico 5 years 5 months ago #10677

  • Gerryman74
  • Gerryman74's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 48
  • Karma: -6
Mario sei un genio..non ci sarei arrivato. Questa formula andrà a completare un ragionamento di una ventina di fogli, tra macro e formule di calcolo complesse..
Grazie di nuovo..
Gerry
The administrator has disabled public write access.

celle a valore dinamico 5 years 5 months ago #10678

  • Marius44
  • Marius44's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 185
  • Thank you received: 38
  • Karma: 14
Ciao Gerry
andiamoci piano coi complimenti :silly: (comunque graditi).
Penso di aver vinto la scommessa con me stesso ed anche in assenza dei Guru (che saluto) ho trovato la soluzione con altre formule, rispettivamente per la data e per 2 o 3 giorni in più:
=MATR.SOMMA.PRODOTTO(--($A$7:$A$150>=$F7);--($A$7:$A$150<=$F7+2);$B$7:$B$150)
=MATR.SOMMA.PRODOTTO(--($A$7:$A$150>=$F7);--($A$7:$A$150<=$F7+3);$B$7:$B$150)

e non sono matriciali (basta confermare con Enter/Invio).

Ciao,
Mario
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.439 seconds