|
Login
  • Page:
  • 1
  • 2

TOPIC: funzione logica nidificata SE(O(SE.NON.DISP.(

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11252

  • mcs032008
  • mcs032008's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 21
  • Karma: 0
Nella colonna A ho una serie di valori numerici e anche #N/D e -- (doppio trattino). In un’altra colonna, vorrei venissero riportati i dati numerici della colonna A e al posto di #N/D e --, un semplice trattino.


col A col risultati desiderati
20 20
#N/D -
62 62
-- -


Ho provato ad impostare la seguente formula nella seconda colonna:
= se(o(se.non.disp.(A1);se(A1=”—“));”-“;A1)
In altri termini, le istruzioni che cerco di inserire seguono questa logica: se A1 è uguale a #N/D o se uguale a “—“, restituisci in B1 “-“. Diversamente, restituisci il valore numerico. Non funziona. Dove sbaglio?
Grazie 1000 a chiunque voglia aiutarmi a risolvere (o semplicemente individuare l’errore) il problema.
The administrator has disabled public write access.

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11253

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

un modo potrebbe esssere questo.

=SE(VAL.NON.DISP(A1);"-";SE(A1="--";A1))

Saluti
The administrator has disabled public write access.

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11254

  • Marius44
  • Marius44's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 185
  • Thank you received: 38
  • Karma: 14
Buon giorno a tutti

@Canapone
Credo che la formula corretta sia questa

=SE(O(VAL.NON.DISP(A1);A1="--");"-";A1)

Ciao,
Mario
The administrator has disabled public write access.

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11255

  • mcs032008
  • mcs032008's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 21
  • Karma: 0
grazie per la gentilezza. ma nn mi risolve il problema. il risultato che mi restituisce applicando la tua formuala è quello riportato nella terza colonna, mentre quello desiderato dovrebbe essere quello riportato nella seconda colonna:

20 20 FALSO
#N/D - -
62 62 FALSO
-- - --

cordialità
The administrator has disabled public write access.

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11256

  • mcs032008
  • mcs032008's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 21
  • Karma: 0
grazie 1000. ma il problema nn sembra essere stato risolto in quanto la tua formula mi restituisce i risultati riportati nella terza colonna. mentre invece a me servono i risultati della seconda colonna
in ogni caso grazie. ciò chge dovrebbe "sparire" è quel maledetto "N/D" che mi compromette poi il calcolo delle formule successive. ecco il risultato ottenuto applicando la tua formula:

20 20 20
#N/D - #N/D
62 62 62
-- - -
The administrator has disabled public write access.

funzione logica nidificata SE(O(SE.NON.DISP.( 3 years 9 months ago #11257

  • Canapone
  • Canapone's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1346
  • Thank you received: 160
  • Karma: 108
Ciao,

saluto subito Mario.

Ho aggiunto un segmento

=SE(VAL.NON.DISP(A1);"-";SE(A1="--";"-";A1))

Allego un esempio.

Credo che gli errori restituiti da i cerca.vert possano creare problemi alla funzione "O".

Sto tirando ad indovinare.
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.637 seconds