|
Login

Chi è online

We have 51 guests online

Ricerca Tips

Ripetere le righe nelle Tabelle Pivot
Tips and Tricks - F.A.Q.

D: Come posso far in modo che un elemento di una tabella pivot non venga ripetuto solo nella prima riga in cui compare?

R: Una pecca delle tabelle pivot è proprio il fatto di non permettere facilmente l'uso di altre formule che si basino sul recordset estratto dalla pivot. Però c'è una scappatoia. Attraverso la funzione SE() possiamo rimediare al problema.
Immaginiamo che la tabella inizi dalla cella A2 e finisca nella colonna E. Per ripetere in tutte le righe il contenuto della prima occorrenza della pivot bisognerà inserire nella cella F2 la seguente formula:
=SE(A2="";F1;A2)
La formula verifica se il contenuto di A2 è vuoto: se lo è significa che bisogna ripetere quello che c'era nella riga precedente (cioé in F1). Se non lo è allora c'è qualcosa di nuovo e possiamo riportarlo.
Copiando la formula nelle righe e colonne successive ricreiamo la tabella pivot con tutte le informazioni utilizzabili in altre formule come SOMMA.SE o CERCA.VERT.
 

Tips & Tricks

Estrarre conto corrente e ABI dal codice IBAN

Formule

Il codice IBAN (International Bank Account Number) è un codice bancario definito a livello internazionale e consiste in: 2 lettere rappresentanti la Nazione (IT per l'Italia), 2 cifre di controllo, il codice BBAN nazionale che, per l'Italia, conta 23 caratteri: CIN (1 carattere), ABI (5 caratteri), CAB (5 caratteri) e...

Leggi tutto...