|
Login

Chi è online

We have 116 guests online

Ricerca Tips

Ripetere le righe nelle Tabelle Pivot
Tips and Tricks - F.A.Q.

D: Come posso far in modo che un elemento di una tabella pivot non venga ripetuto solo nella prima riga in cui compare?

R: Una pecca delle tabelle pivot è proprio il fatto di non permettere facilmente l'uso di altre formule che si basino sul recordset estratto dalla pivot. Però c'è una scappatoia. Attraverso la funzione SE() possiamo rimediare al problema.
Immaginiamo che la tabella inizi dalla cella A2 e finisca nella colonna E. Per ripetere in tutte le righe il contenuto della prima occorrenza della pivot bisognerà inserire nella cella F2 la seguente formula:
=SE(A2="";F1;A2)
La formula verifica se il contenuto di A2 è vuoto: se lo è significa che bisogna ripetere quello che c'era nella riga precedente (cioé in F1). Se non lo è allora c'è qualcosa di nuovo e possiamo riportarlo.
Copiando la formula nelle righe e colonne successive ricreiamo la tabella pivot con tutte le informazioni utilizzabili in altre formule come SOMMA.SE o CERCA.VERT.
 

Tips & Tricks

Eliminare i doppioni da una lista

Scorciatoie & produttivita'

Un problema molto comune agli utenti di Excel è l'eliminazione dei doppioni in una lista: se in una lista di 3.000 elementi vi sono 10 Mario Rossi e 5 Mario Bianchi bisogna ottenere un solo Mario Rossi e un solo Mario Bianchi.

Leggi tutto...