|
Login

Chi è online

We have 59 guests online

Ricerca Tips

Ripetere le righe nelle Tabelle Pivot
Tips and Tricks - F.A.Q.

D: Come posso far in modo che un elemento di una tabella pivot non venga ripetuto solo nella prima riga in cui compare?

R: Una pecca delle tabelle pivot è proprio il fatto di non permettere facilmente l'uso di altre formule che si basino sul recordset estratto dalla pivot. Però c'è una scappatoia. Attraverso la funzione SE() possiamo rimediare al problema.
Immaginiamo che la tabella inizi dalla cella A2 e finisca nella colonna E. Per ripetere in tutte le righe il contenuto della prima occorrenza della pivot bisognerà inserire nella cella F2 la seguente formula:
=SE(A2="";F1;A2)
La formula verifica se il contenuto di A2 è vuoto: se lo è significa che bisogna ripetere quello che c'era nella riga precedente (cioé in F1). Se non lo è allora c'è qualcosa di nuovo e possiamo riportarlo.
Copiando la formula nelle righe e colonne successive ricreiamo la tabella pivot con tutte le informazioni utilizzabili in altre formule come SOMMA.SE o CERCA.VERT.
 

Tips & Tricks

Stampare i commenti

F.A.Q.

D: ho inserito commenti ad alcune celle e li ho resi visibili. Come posso farli apparire anche nella stampa?

Leggi tutto...